戻る
セキュリティ
目次
暗号化
盗聴リスクと暗号化
- 盗聴:盗聴リスクは完全に消し去ることは不可能
- リスクコントロール:対策を講じリスクを許容範囲にとどめること
- 暗号化:盗聴リスクに対して用いられる対策
暗号の種類
暗号とは情報を「特定の条件が整った場合のみ復元可能な一定の規則で変換」して一見意味のない文字列や図案とするものである
- キー(鍵):上記の「特定の条件のこと」
- 平文:暗号化される以前の情報
- 共通鍵暗号:暗号化と複合に同じ鍵を用いる
- 初期段階から用いられてきた暗号化方式
- 共通鍵のことを秘密鍵という場合もある
- 共通鍵は暗号システムの負荷を軽減する。(CPU資源、時間が少なくて済む)
- 鍵の数:「n(n-1)/2個」 → 1対1向き
- CRYPTREC[暗号リスト(電子政府推奨暗号リスト]
- NIST:米国商務省標準局のこと
- 共通鍵暗号の実装例
- DES(Data Encryption Standard)
- IBM開発、NIST標準暗号として採用(1977年)
- 共通鍵[56bitのデータ列(2^56:約7京)
- CPUパワーの向上で総当たりによる解読が可能
- ブロック暗号(ブロック長64bit)
- Triple DES(Triple DES-EDE2,Triple DES-EDE3)
- DESアルゴリズムをそのまま利用
- キーを2つ用意(EDE3は3つ)
- 手順は「暗号化→複合→暗号化」
- AES(Advanced Encryption Standard)
- 現状の共通鍵暗号の実装がAESに集約されている
- AESのスペック
- ブロック暗号(ブロック長128bit)
- 可変長鍵(128,192,256bit)
- 鍵長によって「ラウンド処理」の回数が異なる(128bit→10回、192bit→12回、256bit→14回)
- 暗号化のモード
| ECBモード | 単純な暗号化 |
| CBCモード | 直列のブロックから得た暗号文と次の平文のXORを暗号化 |
| OFBモード | 初期ベクトル(IV)を暗号化して鍵ストリームを作り、鍵ストリームと平文のXORを暗号文とする。次ブロックからは直前の鍵ストリームを暗号化して新たな鍵ストリームを作る。 |
- 公開鍵暗号:暗号化と複合に異なる鍵を用いる
- 暗号化鍵(公開鍵)と複合鍵(秘密鍵)を分離した方式
- 鍵の数:「2n個」 → 1対n向き
- 暗号化処理、複合処理に多くの時間がかかる(同一鍵の共通鍵暗号の数百~数千倍)
- 公開鍵暗号の実装例
- RSA(Rirest,Shamir,Adlemen)
- 名前は開発者3人の名前の頭文字
- 現在RSA Security社が管理
- 大きな数値の素因数分解に時間がかかることを利用
- ECC(楕円曲線暗号)
- 1985年、Kobitz,Miller考案(米国)
- 離散対数問題の解法アルゴリズム(数体ふるい法)に対して強固
- ハイブリッド方式
- 共通鍵は暗号のキーを配布するために公開鍵暗号を利用し、データ本文は共通鍵暗号を用いる。
鍵の分類
- ストリーム暗号:ビット単位で暗号化、平文の先頭から順に暗号を処理
- ブロック暗号:ブロック単位で暗号化
語彙
| 単語 | 説明 | 備考 |
| 初期ベクトル(IV) | 初回の暗号化で直前おブロックの暗号の代わりとなる | |
| 鍵ストリーム | | |
| | |
| | |
| | |
| | |
トップへ戻る
認証システム
認証システムの基本的な考え方
- 認証:ネットワークシステムを利用するユーザが、正当な利用権限を保持しているか否かを確認する行為
パスワード認証
種類
- クリアテキスト認証
- 古くからある
- 平文でサーバへID、PWを送信する
- 「PPP」のPAP(Password Authentication Protocol)がこの方式
- スニファ:ネットワーク上を流れるパケットをキャプチャして内容を解読すること。
- チャレンジレスポンス認証
- クリアテキストの脆弱性を解消
- 手順中でパスワードをネットワーク上に流さない
- [手順]
- ユーザIDをサーバへ送信
- チャレンジコードを返す
- チャレンジコードとパスワードからハッシュ値を生成
- ハッシュ値をサーバへ送信
- サーバが生成したハッシュ値と突合する
- チャレンジコード:使い捨ての乱数
- CAPTCHA:文字列を歪んだ画像などにして、利用者に入力させる方式
- 実装技術としてCHAP
- ワンタイムパスワード(OTP:One Time Password):ログインするごとにパスワードを変更する認証方式
- S/KEY
- ワンタイムパスワードの実装例としては普及している
- チャレンジレスポンス方式の応用で、シーケンス番号を利用(より解読しにくい)
- シード:使い捨ての乱数(チャレンジコード相当)
- クライアントでは「シーケンス番号-1」回の演算、最後1回をサーバ側で行う(複雑化)
- 時刻同期方式
- 乱数の代わりに時刻をトリガーにワンタイムパスワードを生成
- トークン→パスワード生成機構(ハードウェア提供、ソフトウェア提供)
- PIN→個人情報番号
パスワード認証の運用上の注意点
- 辞書攻撃:パスワードとして用いられやすい名詞などをデータベース化して認証システムに繰り返し認証を行う方式
- 総当たり攻撃:考えられるすべてのパスワードの組み合わせを順番に試す方法
- ショルダーハッキング:パスワードを覗き見ること
- ステガノグラフィ:情報を隠蔽する技術。データを別のデータに埋め込んで存在を隠す
バイオメトリクス認証
- 複製が困難な人間の生体情報を用いて本人認証を行うこと
シングルサインオン(SSO:Single Sign On)
- Cookieによる認証
- 同一ドメイン内のみ読取。別ドメインは読取不可
- 共有コンピュータでは他ユーザに見られる脆弱性
- HTTP要求の属性
- domain属性:サーバがクッキーを要求して、クライアントがそれに返信するときどの範囲のサーバまで返信するかを定める。
- secure属性:指定すると、SSL/TLSで通信が暗号化されているときだけ、クッキーを送受信する
- ※同一Webサーバ上にHTTPとHTTPSを使うページが混在している場合、すべtのページでHTTPSを使うか、HTTPとHTTPSでクッキーを使い分ける。
- リバースプロキシによる認証
- リバースプロキシサーバが各サーバの認証に使うユーザIDとパスワードの組やデジタル証明書を保持し、各サーバへのログインを代行する
- SAMLなどの技術を併用し、別ドメインへのシングルサインオンを実装できる
- GARP(GratuitousARP)
- SSOサーバの性質上、自アドレス宛でないパケットを受信することがあり、その際にIPアドレスの重複トラブルを起こす可能性があるため、重複検知に利用する
- 目的アドレスに自分のIPアドレスを挿入し、ARPパケットを送信し、他ノードからのARPリプライによってIPアドレスの重複を検知する。
認証と認可のプロトコル
- OAuth2.0
- アプリケーション連携などを目的としたプロトコル
- サイト間でアクセストークン(メディアやデータの使用権)のみを付与する
- OpenID Connect
- OAuth2.0を拡張したプロトコル。認可だけではなく認証を行い利用者のアイデンティティ情報を安全に交換できる。
- 要素として、JSONを利用している
- SAML
- アイデンティティ情報、認証情報、認可情報を交換する
- OASIS(標準化団体)が規格化
- IdP(アイデンティティプロバイダ):認証情報を提供
- SP(サービスプロバイダ):サービスを提供するために認証情報を要求する
- 認証情報の記述にはXLMを利用
- 伝送にはSOAPを利用
- 柔軟にドメインをまたいだSSOの構築が可能
- IdPとSPが事前に信頼関係を構築し、ユーザIDを連携しておく必要がある
- 企業の期間連携などでは普及したが、BtoCでは向かない
トップへ戻る
デジタル署名
デジタル署名の基本的な考え方
なりすましと改ざんへの対策
- 暗号化→盗聴リスクへの対策
- デジタル署名→なりすまし改ざんリスクへの対策
- 組み合わせて利用
- 盗聴対策にはならない
- 平文に秘密鍵を適用してデジタル署名を生成して送信
- 受信ユーザは公開鍵を用いてデジタル署名を検証、別途送られた平文と比較
- 平文と一致すれば、著名者は本人であり、改ざんされていないことが証明される
メッセージダイジェスト
- 「平文から直接デジタル著名を生成するモデル」は「処理時間が多くかかる」
→平文に対してハッシュ演算を行い、メッセージの漸くを行う。
→これを「メッセージダイジェスト」という
→メッセージダイジェストによってデジタル署名を生成する。
- 著名の長さを統一、処理時間を軽減
- ハッシュ関数は不可逆関数→盗聴されても平文を復元できない
- ※ハッシュ関数では衝突(異なる平文から同じダイジェストを生成)っしないように注意
メッセージダイジェスト、ハッシュ関数の種類
- MD5(MessageDigest5)
- RSA社開発のハッシュ関数
- 平文から128bitのハッシュ値を生成
- SHA(Secure Hash Algorithm)
| Version | ハッシュ値長 | ブロック長 | ラウンド数 |
| SHA-1 | 160bit | | |
| SHA-2 | 224bit,256bit | 512bit | 64 |
| 384bit,512bit | 1042bit | 80 |
SHA-3 (アルゴリズムが異なり信頼性が向上している) | 224bit | 1152bit | 24 |
| 256bit | 1088bit | 24 |
| 384bit | 832bit | 24 |
| 512bit | 576bit | 24 |
PKI(Public Key Infrastructure)
- 公開鍵と秘密鍵が本人と結びつけられた正当なものであることを第三者機関によって効率的に証明するモデル
- 第三者機関が真正性を証明→証明するのは鈎の真正性のみ
- 認証局(CA):鍵の真正性を証明する第三者機関
- 登録局(RA):デジタル署名の登録作業を行う
- 発行局(IA):デジタル署名の発行作業を行う
- プライベートCA:社内サーバに構築するCA
トップへ戻る
マルウェア
コンピュータウイルスとマルウェア
- マルウェア:包括的に「悪意のあるソフトウェア」
- スパイウェア:情報を不正に収集するソフト
- ランサムウェア:利用者のPCやデータなどのリソースをロックして、身代金を要求するソフトウェア
- アドウェア:利用者の意図しない広告を不正に行うソフト
- ルートキット:不正アクセスをサポートするツール群
- ボット:
マルウェアの分類
- コンピュータウイルスの実体:ユーザに隠蔽される形式でメモリや補助記憶媒体に保存されるプログラム
- 最初のウイルスは1988年パキスタンで出回った説がある。
- 初期のウイルスはフロッピーディスクのMBRに感染することが多かった。メールの普及に伴って減少した
- 広義のコンピュータウイルス
- ウイルス:他のプログラムに寄生する
- ワーム:独立して破壊活動が行える
- トロイの木馬:あるトリガによって破壊や増殖を行う
- ポリモーフィック型マルウェア:コードを暗号化する鍵を変化させるもの
- メタモーフィック型マルウェア:意味のないコードを挿入・変換するもの
コンピュータウイルスの3機能
- ウイルスの定義→コンピュータウイルス対策基準(1990年通商産業省[現経済産業省]
→次の3つの機能の内1つ以上を持つもの
- 事故電線機能:他ノードに自身をコピーする機能
- 潜伏機能:期間や条件を定め沈黙している機能
- 発病機能:悪意のある処理を実行する機能
ルートキット
- ルートキット:情報システムを攻撃しようとする攻撃者が使うソフトウェアのセット
- 特徴
- 侵入痕跡となるログを消す
- 悪意あるプロセス・タスクを隠蔽する
- 悪意あるファイルを隠蔽する
- バックドアを作る
- 分類
マルウェアへの対策
- ウィルスチェックソフトウェア
- ネット羽アークからの遮断
マルウェア観戦後の対応
- 感染したシステムの利用停止
- ユーザへのアナウンス
- マルウェアと影響範囲の特定
- 復旧手順の確立と復旧作業
- 原因の特定と対応策の策定
- 関係機関への届け出
- 初動対応:二次感染の防止、管理者への通報の徹底
- 復旧:イメージファイルを保存しておき、復旧手順を高速化する
※復旧作業手順は記録し、後日監査して再発予防策を策定する
- 事後処理:再発防止策の策定と実施、関係機関への通知
CVSS
共通脆弱性評価システム(CVSS:Common Vulnerability Scoring System)
- 各ベンダの脆弱性情報、評価や対策が異なるため、ベンダ依存のないように、オープンで包括的、汎用的な同一基準下の評価方法として作られた。
- 現在はCVSSv3が使われる
CVSSの3つの基準
- 基本評価基準:脆弱性の特性を評価する
- VBSS基本値:脆弱性固有の深刻度が分かる基準、固定値
→機密性、完全性、可用性のCIAへの影響の評価
- 現状評価基準:脆弱性の現在の深刻度を評価する
- CVSS現状値:脆弱性の状態を表す基準、対応度によって可変値
→攻撃コード、対策の有無等を基準に評価
- 環境評価基準:最終的な脆弱性の深刻度を評価する
- VBSS環境値:利用者が脆弱性へどう対応するかを表す基準、利用者ごとに可変値
→対象製品の使用状況、二次被害の大きさなどを評価
トップへ戻る
サイバー攻撃
クロスサイトスクリプティング
Reflected XSS
- 反射型と呼ばれるXSS
- リクエストにスクリプトが含まれ、レスポンスページにスクリプトが埋め込まれてしまうタイプの脆弱性
- 利用者がリンクにアクセスすることでスクリプトが実行される
Stored XSS
- 格納型と呼ばれるXSS
- 脆弱性のあるWebアプリケーションにスクリプトを保存させ、他のユーザがリクエストしたときにスクリプトを含むWebページに返し実行させる。
DOM Based XSS
- DOM、つまりブラウザで実行されるためWebサーバ、Webアプリ側の検査ではチェックで検出されない
- エスケープ処理をして、スクリプトを安全に保つ必要がある
インジェクション攻撃
SQLインジェクション
- SQLまたは不正な文字列を挿入させ、別の意図しない動作を引き起こすこと。
HTTPヘッダインジェクション
- HTTPヘッダに不正な文字列を挿入することでWebサーバやブラウザに意図しない動作を指せる攻撃手法
- クエリストリングに開業を含め悪意のあるヘッダを挿入する
OSコマンドインジェクション
- OSコマンドを呼び出す関数に不正な文字列を挿入して、開発者が意図していない動作を実行させる
- 対策
DoS攻撃(Denial of Service)
- サービス停止攻撃の1つ、大量の世紀サービス要求を送りトラフィックやタスクをビジーにする
- 分散DoS(DDoS)
DNS amplification(DNSamp,DNS増幅攻撃)
- トラフィック増大によって攻撃
- オープンリゾルバを狙ったり、DNSクエリレスポンス情報が大きいドメインを選んで狙ったり、またDNSクエリレスポンスが大きくなる情報をDNSサーバに登録したりする手口がある。
ICMP Flood(Ping Flood)
- ICMPエコー要求を大量に送信して攻撃(ping)
- 対策
- ※どんな通信でも大量に送ればDoS攻撃となる。
- 種類
- F5アタック(ホームページFlood)
- メールFlood
- Smurf攻撃:送信元を攻撃先サーバに偽装してエコー要求をブロードキャストしネットワーク上のICMPエコー応答パケットを集中させる
TCP SYN Flood
- TCPの3ウェイハンドシェイクに付け込んでだ攻撃方法/li>
- 最後のACKに応答せず、コネクション資源を確保させビジーにさせる
- 対策
- 不要なTCPポートを閉じる
- 時間経過で不成立コネクションは強制終了させる
リフレクタ攻撃(反射型攻撃、RDoS)
- 直接攻撃ではなく踏み台を挟む
- 分散反射型攻(DRDoS):リフレクタの数を増やしたもの
- 攻撃者のパケットに大きなパケットを生成するサービスをリフレクタとする。
- パケットを偽装しやすいUDPベース(DNS,NTP)が好まれる。
バッファオーバフロー
- バッファを越えるサイズのデータを送信してあふれさせる攻撃
スタック攻撃
- スタックには、変数の内容や次に実行するコマンドの格納、アドレスなどのデータがある。
- スタックを溢れさせ、誤動作や他のプログラムを実行させる。
ヒープ攻撃
- ヒープ領域は、動的に確保したり、解放したりするメモリ空間。
- 規定サイズより大きいデータを挿入して、隣接メモリ領域を上書きする。
対策
- バッファオーバーフローを生じる関数や特定の使用方法をしない
- 入力値のチェック
- バッファオーバーフローゼロの完璧なプログラムは不可能として全体のセキュリティシステムを構築するのが現実解
- データ実行防止機能(DEP:Data Execution Prevention):メモリ空間(コード領域以外)でのコードの実行を禁止する対策法
- アドレス空間配置ランダム化(ASLR:Address Space Layout Randomitation):整然と並んでいるアドレス空間をランダムに配置する対策法
その他の攻撃手法
- ボット:感染したコンピュータを支配下に置き、遠隔操作するマルウェア
- ポートスキャン:すべてのポートにパケットを送信し、応答の有無でどのようなサービスをうごかしているか推測する準備攻撃
- IPスプーフィング:IPアドレスを偽装して正規のユーザのふりをする攻撃手法
- DHCPスプーフィング:偽のDHCPサーバ、DHCPクライアントを立てて、ネットワークを攻撃する手法。(対策:DHCPスヌーピング)
- MITM攻撃(Man-in-the-middle):中間者攻撃、二者間で通信が行われている間に割り込んで互いの通信を仲介する攻撃
- セッションハイジャック:二者間で張っているセッションを乗っ取ってしまう攻撃手法
- TCPでは、IPアドレス、TCPポート番号、シーケンス番号でセッション管理するが、特定されないようにTCPポート番号のランダム化、推測困難なシーケンス番号を採番することで防ぐ。
- HTTPにはセッション管理機能がないが以下の方法でセッションIDをやり取りする。
- URLのクエリストリング
- HTMLのhiddenフィールド
- Cookie
- クロスサイトリクエストフォージェリ(略記:CSRF,XSRF):利用者があるサーバにログイン状態であることを悪用して攻撃者がサーバを使う攻撃
- スパムメール:不特定多数のユーザに電子メールを送る行為、マルウェアの温床となりうる。
- 標的型攻撃:ウイルス、フィッシング、ソーシャルエンジニアリング
- スキャベンジング:組織が使う標準書類形式などを入手する方法
- テンペスト技術:情報機器が発する電磁波を傍受して不正に情報を取得する技術の総称
トップへ戻る
LANにおけるセキュリティ対策技術
ファイアウォール
- パケットフィルタリング型ファイアウォール
- ヘッダ情報を用いてパケットの通過/不通過を決定する
- 「送信元IPアドレス」「宛先IPアドレス」「送信元ポート番号」「宛先ポート番号」「プロトコル種別」
- 「ルールベース」(フィルタリングルール表)を保持する。
- ホワイトリスト:安全な通信のリスト、この条件で通信を許可する
- ブラックリスト:危険な通信のリスト、この条件で通信を拒否する
- 利用しないアプリケーションのポートは閉じて置く(セキュリティ上重要)
- アプリケーションゲートウェイ型ファイアウォール(L7ゲートウェイ)
- アプリケーション層の内容を解釈して通信の適否を決定する。
- HTTP向け、SMTP向けなどのバリエーションがある。
- Webリクエスタ:一度クライアントの要求を解釈し問題がない場合にWebリクエストをゲートウェイのものとして再構成して送信する。
- ステートフルインスペクション:前後のパケットや上下のプロトコルとの整合性が取れていないかを検査する
- ディープパケットインスペクション:アプリケーション情報を使って検査する
- プロキシサーバ
- L7ゲートウェイで特にhttpを扱うもの
- Webページの内容をキャッシュし、キャッシュに保存しているページはWANに問い合わせをせずにローカルノードへ返信する。→WANトラフィックを軽減する
- WPAD(Web Proxy Auto-Discovery)
- プロキシサーバで各PCに自動設定を適用するプロトコル
- プロキシサーバ設定用のスクリプト「proxy.pac」
- リバースプロキシサーバ
- サーバサイドで用意されるプロキシサーバ、シングルサインオンを実装するために使われる技術の一つ
- フロントエンド認証を行い、他のサーバへの認証行為を自動的に代行
- WAF(Webアプリケーションファイアウォール)
- HTTP,HTTPSを解釈して、サイバー攻撃からWebサーバを守る機器
- ポジティブモデル:原則として通信を遮断し、条件に一致する通信のみ許可
- ネガティブモデル:原則として通信を許可し条件に一致する通信のみ遮断
DMZ(DeMilitarized Zone)
- 公開サーバ用の第3のゾーンを作成することにより、ローカルネットワークを高いセキュリティレベルで守ることができ、公開サーバに対しても最低限のセキュリティレベルを維持できるようになる。
パーソナルファイアウォール
- クライアントノードにインストールして利用するソフトウェア
- ※多段防御(Multi-LayerProtoccol)
その他対策技術
- ハニーポット:ダミーとして設置されるサーバやネットワーク機器の総称
- DHCPスヌーピング:DHCPスプーフィングに対応する機能。バインディングテーブルと呼ばれるクライアント情報のリストを作成し、DHCPサーバが配布していないIPアドレスからの通信を見分けることができる。
IDS(Intrusion Detection System)
パケットフィルタリングなどで検出が困難な攻撃に対処するためのシステム
- HIDS(ホスト型):ホストにインストールしてそのホスト自身を監視する
- NIDS(ネットワーク型):パケットをキャプチャできる場所に設置してネットワーク全体を監視する
- Misuse検知法:シグネチャに合致する兆候を管理者に警告ネットワーク遮断したりする
- Anomaly検知法:システムの正常な稼働状態から外れた際に委譲を検出する
シグネチャ:攻撃パターンのデータベースで、パターンに合致する兆候を通告したりねっと遮断する
- フォールスポジティブ:正常なアクセスを不正アクセスと検出すること
- フォールスネガティブ:不正アクセスを正常なアクセスと検出する
- インラインモード:直列にIDSを配置。パケットを取りこぼさないが、ボトルネックとなりうる
- プロミスキャスモード:ミラーポートにIDSを配置
トップへ戻る
ユーザ認証におけるセキュリティ対策技術
PPP(Point to Point Protocol)
- WANでのモデム間通信時にMACフレームを置換する技術。
- に転換を電話回線で結ぶために開発されたデータリンクプロトコル、汎用性が高く物理媒体に依存しない。PPP単体で認証を行うことが可能
- 隣接したモデム同士の通信が主用途
| フラグ | アドレス | 制御 | タイプ | データ | FCS | FCSフラグ |
| 1oct | 1oct | 1oct | 2oct | 1500oct | 4oct | 1oct |
NCP(Network Control protocol)
IPCP(Internet Protocol Control Protocol)
IPと接続する場合にNCPとしてIPの設定をネゴシエーションする
LCP(Link Control Protocol)
LCPネゴシエーションのプロセス
- →Request(MRU1500,CHAP認証)
- ←Request(CHAPサポート外)
- →Request(MRU1500,PAP認証)
- ←ACK(OK)
MRU(Maximum Receive Unit)
- LCPエコー:リンク接続状態を確認するためのパケット。LCPエコーリクエスト、LCPエコーリプライの応答によって接続確認を行う
PPPoE(PPP over Ethernet)[RFC2516]
- イーサネット上でPPPを利用し、PPPフレームをMACフレームでカプセリングして送信する技術。ADSLのデータリンク方式として採用
- ADSLは各ユーザが同じローカルネットに属しているので認証サーバへの接続手続きを電話回線のダイヤルアップと同等の手順で行おうとした結果PPPをMACフレーム化する方式となった。
認証技術
PAP(Password Authentication Protocol)
- PPPで利用される最も基本的な認証プロトコル。クリアテキスト。
CHAP(Challenge Handshake Authentication Protocol)
- チャレンジハンドシェイク方式を利用して暗号化された認証データを送信する。
EAP(PPP Extensible Authentication Protocol)
- オプションとして利用される
- 代表的なEAP(EAP-TLS,MS-CHAP,LEAP,PEAP,EAP-MD5,etc)
※セキュリティ上はCHAPを選択し、LCPネゴシエーションでPAPを要求された場合は拒否する設定を推奨する
RADIUS(Remote Authentication Dial-In User Service)[RFC2138]
- 外界に経路を開くアクセスサーバに認証情報があるという脆弱性を緩和するためにアクセスサーバと認証ポイントを分離したモデル
- もともと、「Livingston Enterprise」が自社アクセスサーバ用に開発したプロトコル
- アクセスサーバの台数制限はない
- 認証要求の暗号文はRADIUSサーバ上で複合される
- アクセスサーバが増えても、認証情報をRADISUサーバ上で一元管理できる。
- RADIUSクライアント⇔アクセスサーバ
DIAMETER
- RADIUSの後継プロトコル。RADIUSと上位互換がある
- RADIUSで不可能だったサーバクライアント間の双方向の情報交換やベンダ独自の拡張情報を扱える余地を大きくしたこと、セキュリティの強化など改良されている。
Kerberos(Kerberos Ver.5)[RFC1510]
- 暗号化に任意のアルゴリズムを選択できる。将来的な暗号理論の拡張に備えた。
- レルムという概念を導入している。
レルム
- DNSやWindowsのドメインのような概念
- レルム内ではユーザIDやパスワードは一切ネットワーク上を流れない。
KDC(Key Distribution Center)
- ASプロセス(Authentication Server)
クライアントの認証を行う。
- TGSプロセス(Ticket Granting Server)
チケットの発行を行う。
- KDBプロセス(Kerberos DataBase Server)
プリンシパルの共通鍵を管理する
※プリンシパル:レルム内においてKDCに管理されるすべてのノードのこと
認証プロセス
- プリンシパルがASにチケットを要求
- ASはKDBを検索し、正当なプリンシパルなら共通鍵で暗号化したチケットを返信
- プリンシパルはチケットをTGSに送信し、サーバの仕様許可証を要求する
- TGSはサーバ使用許可証とサーバ通信に使う共通鍵を返信
- サーバと通信を開始
SSL/TLS
- セキュリティ通信プロトコル暗号化と認証、トランスポート層~セッション層で動作
- SSL(Secure Socket Layer)[ネットスケープ社]
- TLS(Transport Layer Security)[TCPとの関係が強い]
- ※プログラマの視点でTLSはTCPの代わりのように機能する。
SSL→2014年 POODLE攻撃(脆弱性発覚)→RFC提案→TLS[RFC2246]
TLSでできること
- サーバ認証 → サーバ証明書
- クライアント認証 → クライアント証明書
- セッションの暗号化
サーバ証明書
- DV(ドメイン確認):一番取得が簡単、ドメインと企業の一致を保証しない、証明書にはド会陰情報しかない。
- OV(組織実在確認):組織の実在を確認しないと発行されない、証明書には組織情報も記載される
- EV(拡張確認):最も厳格な確認プロセスを経て発効されるCAブラウザフォーラムのEVガイドラインが確認基準、この証明書を持っているサイトにアクセスするとブラウザのアドレスバーが緑色になる
TLSの通信手順
- ハンドシェイク
- サーバを認証する
- 暗号化アルゴリズムを決める
- 暗号化鍵とMAC鍵を作る
- データの伝送
- TLS Recordプロトコル
- データフラグメントから計算したMACが各パケットに挿入される
- Recordヘッダに書かれるもの
- コンテンツのタイプ(アプリケーションデータ、アラート、ハンドシェイク、チェンジ・サイファ・スペック)
- パケットのサイズ
- TLSバージョン
言葉
| 言葉 | 意味 |
| 前方秘匿性(Forward secrecy) | 漏洩以前に行われた暗号通信が不正に複合されないことを保証する |
VPN
種類
- インターネットVPN
- 低コスト、帯域保証がない、VPNゲートウェイなどの設置、設定はユーザが行う。どのノードからでもVPNアクセスできる。
- IP-VPN
- 通信キャリアの広域IP網などを利用する。インターネットVPNより割高になる。企業向けメニューが揃っている。VPN装置の設定もキャリアが行う。
- MPLSを使い、ラベルによってユーザが分離され、通信効率とセキュリティが向上する。
- SSL-VPN
- 認証と暗号化にTLSを利用する方式。IPに関連する設定の偏向を意識せずVPNを構成できる利点がある。
VPNの基本構成
VPNの2つのモード
- トランスポートモード:通信ノードが直接暗号化を行う。IPヘッダは暗号化されないエンドノードすべてにVPNソフトをインストールする必要がある。
- トンネルモード:VPNゲートウェイを利用して暗号化する。IPヘッダはVPNゲートウェイが付与する。
※「VPNゲートウェイ」=「セキュリティゲートウェイ」→IPsecを使うもの「IPsecゲートウェイ」
VPNを実現するプロトコル
IPsec
- IPレベルで暗号化や認証、改ざん検出を行うセキュリティプロトコル
- IPv4:オプション仕様
- IPv6:標準プロトコル
- 利点:従来IP利用の機器が大きな変更なく利用できる。
(S/MIMEなどはアプリケーションごとに個別設定が必要)
- ※IP in IP:IPパケットをっカプセル化してトンネリングを行う技術(暗号化、認証なし)
- IPsecの通信手順
- IKEフェーズ:「IKE(Internet Key Exchange)[RFC2409]」
- パケットにセレクタを利用
- セレクタの定義する方法でIPsec通信を行う
- SA(Security Association)という仮想通信炉を作成
IKE SA:暗号化方式の決定と鍵の生成、交換
- 暗号化アルゴリズムの決定(公開鍵暗号)
(将来拡張に備えてある→任意に選択)
- 「相互ネゴシエーションする」
- IPsecフェーズ
- SA(IPsecSA)を送信用、受信用それぞれ作成する。(共通鍵暗号)
- NATトラバーサル:NAT環境下でVPNを実現する技術(VPNパケットはUDPカプセル)
- VPNパススルー:VPNパケットに対しk、NAPTを適用せず、送信元IPドレスだけを書き換えて素通しさせる技術
IPsecのフレーム構造
- ESP(Encapsulationg Security Payload)[RFC2406]
- IPsecで使われるフレーム構造。暗号ペイロード
- IPsecパケット
- SPI情報:暗号化に必要
- IPヘッダ(トンネルモード時):着信時にヘッダ情報をベリファイするため
- 認証データ:ノードの認証と改ざん検出のため(メッセージダイジェスト)
- AH(Authentication Header)
- 認証と改ざん検出を行う。ESPと組み合わせて使う。認証ヘッダ
- ICV(Integvity Check Vector):改ざん検出のチェックサム
- IPsecの動作モード
- LAN間接続(IPアドレス認証)
- リモートアクセス(任意認証)
PPTP(Point to Point Tunneling Protocol)[RFC2637]
- データリンク層、暗号化、認証、改ざん検出を行うプロトコル
- L3でIPX(IP以外)を使っているVPN構成が可能
- 認証
- MS-CHAP(MicrosoftCHAP):マイクロソフト開発のCHAP拡張
- MPPE(Microsoft Point to Point Encryption)
- GRE(Generic Routing Encapsulation)
- RC4:PPTPの暗号化アルゴリズム(PPTPでは暗号ネゴシエーションしない)
L2TP[RFC2661]
- PPTPの認証手段などを拡張した仕様
- セッション層にUDPを利用。
- 1つのトンネルで複数のセッションを張れる
トップへ戻る
高境界線におけるセキュリティ対策技術
トップへ戻る
セキュリティ関連規格
CC
- 1996年に最初のバージョンが発行された
- バージョン2は「ISO/IEC15408」として国際標準化された。(現在でも「ISO/IEC15408」を「CC」と呼ぶことがある)
- 現在の最新版は「CC/CEMバージョン3.1リリース4」
- CEM:評価に使用される手法を定めた規格
- EAL7が最も高い評価。EAL5以上は軍事用など特殊な用途に限られる
| 規格名 | 主体 | 用途 | 目的 |
| TCSEC | 米国防総省 | もとは軍事システム向け | 評価基準 |
| CC | ISO(ISO/IEC15408) | 商用システムを想定 | 評価基準 |
| CCRA | 欧米6ヵ国7機関 | 商用システムを規定 | CC認証を国際的に相互承認 |
ISMS
- ISMS:「情報セキュリティマネジメントシステム」
- JIPDEC:国内で「情報セキュリティマネジメントシステム適合性評価制度」を運用。各種情報セキュリティマネジメントシステムに関する規格が使われている
- 「情報セキュリティマネジメントシステム」に関する規格は2つの系譜がある。
- ベストプラクティス:組織の情報セキュリティ管理の仕組みはこうあるべき、という優れた事例を文書化したもの。
- 「BS7799-1」:英国規格
- 「ISO/IEC17799」:国際標準規格
- 「ISO/IEC27002」:国際標準規格(2007年)
- 「JIS X 5080」:国内規格
- 「JIS Q 27002」:国内規格(2006年)
- 「ISO/IEC20000」:ITサービスマネジメントシステムの構築に関する国際標準規格。「マネジメントシステム」を構築するという点において、基本的な考え方はISO/IEC 27000などと同じ。英国規格ITILをベースに作られている
- 認証基準:ベストプラクティスをもとに組織が作り上げたマネジメントシステムが本当に実効性があり、他の各規約などと整合しているかを審査するために使われる。
- 「ISMS認証基準」:英国規格「BS7799-2」をもとに作られた
- 「ISO/IEC27001」:認証基準の国際標準化規格。2005年10月に公開。
- 「JIS Q 27001」:「ISMS認証基準」が2006年5月に移行したもの。「ISMS適合性評価制度」は継続している。
- CIA
- 機密性(Confidentiality):許可された正当なユーザだけが情報にアクセスできる
- 完全性(Integrity):情報が完全で正確であること。情報の一部分が失われたり、改ざんされたりすると完全性が失われる
- 可用性(Availability):ユーザが情報を必要とするときに、いつでも利用可能な状態であること)
- 「JIS Q 27000シリーズ」の用語
- 情報セキュリティ事象:情報セキュリティ方針への違反や、対策に不具合がある可能性、セキュリティに関係すると思われる未知の状況
- 情報セキュリティインシデント:望まないセキュリティ事象や、予期しない情報セキュリティ事象で、業務運営を危うくしたり、セキュリティの脅威になる可能性が高いもの
ISMSを構築する手順
- ISMSの範囲を定義する
- 特に適用対象の境界を明確にし、適用を除外する対象についてそれが正当である理由を明文化する
- ISMSの基本方針を策定する
- ISMSの方向性と行動指針を示す。
- 組織の取り組みを明確にする。
- 経営陣の参画を明確にする。
- リスクアセスメントの体系的な取り組み方法を策定する
- リスクアセスメントの方法とリスク評価基準、リスクの需要水準を決める。
- リスクを特定する
- リスクアセスメントを実施し、リスクを分析・評価する
- リスクのための選択肢を特定し、評価する
- リスクに対応するための選択肢(リスク最適化、リスク回避、リスク移転、リスク保有)を決定する
- リスクに対応した管理目的および管理策を選択する
- リスクを最適化する場合、管理目的と管理策(JIS Q 27002)を選択する
- 経営陣から残留リスクの承認を得る
- 経営陣からISMS導入および運用の許可を得る
- 適用宣言書を作成する
- 選択した管理策と選択しなかった管理策を提示し、理由を説明する。
用語
| 言葉 | 説明 |
| リスク | 一般的にリスク=危険だが、リスクが高い(=見返りも大きい)場合があるように、リスクには「不確実性」という意味もある。 |
| フォレンジックス | 情報システムの状態や利用履歴を記録し、公的な証拠能力を担保する水準で保管すること、もしくはそのシステム自体を指す用語。従来のシステムログのような狭義のログだけでなく、広義では業務活動全般のログが収集対象となる。 |
JIS Q 31000シリーズ
リスクマネジメントのやり方はJIS Q 31000シリーズで標準化されている。JIS Q 27000シリーズに基づいてセキュリティマネジメントシステムを構築していくと、リスクマネジメントの実施に直面するが、両者は整合性を保つように設計されている。
- JIS Q 31000:ISO31000をもとに作られた規格。リスクマネジメントの原則と指針を示している。この文書は「リスク」を「あらゆる業態および規模の組織は、自らの目的達成の成否および時期を不確かにする外部および内部の要素並びに影響力に直面している。この不確かさが注鬼の目的に与える影響をリスクという」と定義している。
- JIS Q 31010:リスクアセスメントについて定めたもの。IEC/ISO31010を基にして、リスクアセスメント技法についてまとめられている。
リスクアセスメントのプロセス:リスク特定→リスク分析→リスク評価→リスク対応
リスクを分析するときには、リスクが顕在化したときの結果とリスクの起こりやすさを基準にする
その他のセキュリティ関連規格
- システム監査基準とシステム管理基準
| システム監査基準 | システム監査の品質を確保して、有効な監査にするための、システム監査人の行動規範 |
| システム管理基準 | 経営戦略に沿った情報システム戦略の立案と、それに基づいた効率的な投資、リスク低減をするための実践規範 |
- 情報セキュリティ監査制度
| 助言型監査 | 改善点の助言が主眼 |
| 保証型監査 | 対策が一定の水準に達しているか証明する |
- JIS Q 15001:「個人情報保護法に関するコンプライアンス・プログラムの要求事項」という名称でも問われますが、必ずJIS Q 15001と注釈が入る。JIS Q 15001は個人情報保護を行うマネジメントシステムが構築されているかを認定するもの。ISMS同様、個人情報保護方針の作成、計画、実施・運用、監査、見直しの一連のPDCAサイクルを作る
- プライバシーマーク制度:「日本情報経済社会推進協会(JIPDEC)」が運用する認定制度で、個人情報保護の取り扱いが確立されているかを第三者機関が審査・認証する。その際に使われる規格はJIS Q 15001で認定取得を目指す企業はこれに準拠したマネジメントシステム(JIS Q 15001ではコンプライアンス・プログラムという)を構築する必要がある。
- サイバーセキュリティ戦略:サイバーセキュリティ基本法に基づいて、内閣サイバーセキュリティセンターが定めた戦略。サイバー空間に係わる認識、目的、基本原則、目的達成のための施策、推進体制、今後の取り組みの各章から成る。
- 「自由で安全なサイバー空間を発展させ、経済の持続的発展、安心な社会の実現、国際社会とにほんの安全保障を実現する」という目的
- 5つの基本原則
- 情報の自由な流通の確保
- 法の支配
- 開放性
- 自律性
- 多様な主体の連携
セキュリティ関連組織
CSIRT
- 情報セキュリティにまつわるインシデントが起きた時に、対応する組織の総称。
- 初動対応はもちろんのこと、情報を収集しての原因分析までを行う。
- 企業や学校と言った組織単位のものから、国際連携を行う大規模なものまで、様々な水準・大きさのCSIRTが混在している。
- CSIRTガイド:JPCERT/CCがまとめた、CSIRTを構築・運用する経営者、CSIRTメンバのためにCSIRTの組織と活動を説明して、何を行うべきかを明らかにしたもの。「どんなインシデントに対応するのか」サービス対象によって6つに分類
| 組織内CSIRT | 組織にかかわるインシデントに対応する企業内CSIRT |
| 国際連携CSIRT | 国や地域を体操とするCSIRT。国を代表するCSIRT |
| コーディネーションセンター | 他のCSIRTをサービス対象とするCSIRT。各CSIRT間の情報連携や調整を行う。 |
| 分析センター | インシデントの傾向分析やマルウェアの解析を行う。 |
| ベンダチーム | 自社製品の利用者をサービス対象とするCSIRT。自社製品の脆弱性を見つけ、パッチの配布などを行う。 |
| インシデントレスポンスプロバイダ | CSIRTの機能を有償で請け負う組織。セキュリティベンダが顧客に対して、CSIRTサービスを提供する。 |
- JPCERT/CC:日本を代表するCSIRT
- 組織内CSIRT:利用者からのインシデント報告を受け、対応すること。外部のCSIRTと適切な関係を保ち、状況に応じて依頼できる状況を作っておく。
内閣サイバーセキュリティセンター
- サイバーセキュリティ基本法が施行され、第25条により内閣には「サイバーセキュリティ戦略本部」が、内閣官房組織令により内閣官房には「内閣サイバーセキュリティセンター(NISC)」が設置された。
- 「IT戦略本部」:内閣に置かれている。「サイバーセキュリティ戦略本部」と連携を取る。
- 「NSC(国家安全保障会議)」:内閣に置かれている。「サイバーセキュリティ戦略本部」と連携を取る。
- 「内閣サイバーセキュリティセンター」は技術動向を調査・研究し、サイバーセキュリティ政策の中長期計画を立案する。
トップへ戻る